Кумир. Программа калькулятор. Пример работы оператора выбора

Программа калькулятор. Пример работы оператора выбора

Кумир. Программа калькулятор. Пример работы оператора выбора

На данном уроке рассмотрим оператор выбора в среде программирования КуМир

Общий вид команды выбор:

выбор
при условие 1 : серия 1
при условие 2 : серия 2
...
при условие n : серия n
иначе серия n+1
все
алг калькулятор
нач
цел m,a,b
вывод 'Введите 1 число: '
ввод a
вывод 'Введите 2 число: '
ввод b
вывод 'Если вы хотите сложить, нажмите 1; '
вывод 'Если вы хотите умножить, нажмите 2; '
вывод 'Если вы хотите вычесть, нажмите 3; '
вывод 'Если вы хотите разделить, нажмите 4; '
ввод m
выбор 
при m=1: вывод 'Ответ =',a+b
при m=2: вывод 'Ответ =',a*b
при m=3: вывод 'Ответ =',a-b
при m=4: вывод 'Ответ =',a/b
все
кон

Программу на языке «Паскаль» вы можете посмотреть здесь

Foxford
Добавить комментарий

Введите правильный ответ: * Лимит времени истёк. Пожалуйста, перезагрузите CAPTCHA.

:) :D :( :o 8O :? 8) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :wink: :!: :?: :idea: :arrow: :| :mrgreen:

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.