Вывести на экран сумму положительных четных чисел в массиве

Вывести на экран сумму положительных четных чисел в массиве

Вывести на экран сумму положительных четных чисел в массиве

На данном уроке выведем сумму положительных чётных элементов элементов массива в одномерном массиве на языке программирования  КуМир.

алг вывести на экран сумму положительных четных чисел в массиве
нач цел таб x[1:5], цел i,s
s:=0
вывод 'Введите 5 чисел: '
нц для i от 1 до 5
ввод x[i]
кц
нц для i от 1 до 5
если mod (x[i],2) =0 то
если x[i]>0 то
s:=s+x[i]
все
все
кц
вывод "Ответ: ", s
кон

Для проверки программы введите последовательно числа:

3
9
4
2
-5
Ответ: 6

Самостоятельная работа

Вывести на экран произведение отрицательных нечетных чисел в массиве.

Ответ напишите в комментариях этого поста

Понравилась статья? Поделиться с друзьями:
Добавить комментарий

Введите правильный ответ: * Лимит времени истёк. Пожалуйста, перезагрузите CAPTCHA.

:) :D :( :o 8O :? 8) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :wink: :!: :?: :idea: :arrow: :| :mrgreen: